WARNING: DirectCompute is not available, using BC6H / BC7 CPU codec

Jun 24, 2014 at 5:53 PM
Subject says it all. I'm wondering how to diagnose this - BC7 encoding is painfully slow and I would love to use my GPU to help with this.
Coordinator
Jun 24, 2014 at 6:22 PM
This means your 'default' Direct3D device does not support DirectCompute 4.x. It could be that you have both a GPU and an Integrated Graphics part and the drivers are setup to use the Integrated Graphics part as the 'default' Direct3D device.

You could modify texconv.cpp's CreateDevice to always output the name of the device before checking for DirectCompute support which should tell you what device is the 'default' one.
Marked as answer by walbourn on 6/24/2014 at 11:22 AM
Jun 24, 2014 at 7:53 PM
Ah, that gave me a clue. Windows update needed a restart as it upgraded my NVIDIA drivers and for some reason the default D4D device was unavailable.

Incidentally, I disabled my integrated Intel graphics in the device manager to force the issue.

Works now, thank you!